© Copyright 2012-2019 Josh Sobel

Arc the Dragon Compatibility Info

Arc the Dragon officially supports Maya 2015+, and was created in Maya 2016. Maya 2016.5 or newer is recommended, as improvements to parallel evaluation will drastically increase your playback and manipulation speed once you start animating.